The issue has been fixed and events are loading normally. The incident is closed.
Posted Aug 24, 2026 - 12:33 UTC
Monitoring
Events requests are showing positive signs of recovery. Our engineering team will keep monitoring for the next half hour.
Posted Aug 24, 2026 - 11:59 UTC
Update
We have reduced request latency and timeouts, which has decreased the impact on users. Our investigation is still ongoing as we work to identify the root cause and restore normal performance. We will provide another update when the situation changes.
Posted Aug 24, 2026 - 11:13 UTC
Update
We are continuing to investigate this issue which seems localized to events within alerts.
Posted Aug 24, 2026 - 09:32 UTC
Investigating
We are currently investigating latency and timeouts (on events and alerts).
Posted Aug 24, 2026 - 09:12 UTC
This incident affected: Web application and Detection.